package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<h1>(.+?)<\/h1>)<img class=".*?" alt="[^"]+" (src="[^"]+")>`)
var str = `<h1>Bla-bla-bla</h1><img class="class" alt="image" src="img.jpg">
`
var substitution = "\1<img \3 alt="\2">"
fmt.Println(re.ReplaceAllString(str, substitution))
}