// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(<h1>(.+?)<\/h1>)<img class=".*?" alt="[^"]+" (src="[^"]+")>"#).unwrap();
let string = "<h1>Bla-bla-bla</h1><img class=\"class\" alt=\"image\" src=\"img.jpg\">
";
let substitution = "\\1<img \\3 alt=\"\\2\">";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}