import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<h1>(.+?)<\\/h1>)<img class=\".*?\" alt=\"[^\"]+\" (src=\"[^\"]+\")>";
final String string = "<h1>Bla-bla-bla</h1><img class=\"class\" alt=\"image\" src=\"img.jpg\">\n\n";
final String subst = "\\1<img \\3 alt=\"\\2\">";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}