#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(<h1>(.+?)<\/h1>)<img class=".*?" alt="[^"]+" (src="[^"]+")>"
Local $sString = "<h1>Bla-bla-bla</h1><img class="class" alt="image" src="img.jpg">" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "\1<img \3 alt="\2">"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)