#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((http[s]?:\/\/|w{3}\.|http[s]?:\/\/w{3})?[a-z0-9\.]{3,}\.(com|co|net|info|tour|me|org|edu|ir))$"
Local $sString = "https://babakashtari.combabak.com " & @CRLF & _
" http://babakashtari.com" & @CRLF & _
"https://www.babakashtari.com" & @CRLF & _
"babak.ashtari.com" & @CRLF & _
"babak1359.com" & @CRLF & _
"www.yahoo.com" & @CRLF & _
"babakwww.ashtari.com" & @CRLF & _
"www.tehranbazar24.com" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")