import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((http[s]?:\\/\\/|w{3}\\.|http[s]?:\\/\\/w{3})?[a-z0-9\\.]{3,}\\.(com|co|net|info|tour|me|org|edu|ir))$";
final String string = "https://babakashtari.combabak.com \n"
+ " http://babakashtari.com\n"
+ "https://www.babakashtari.com\n"
+ "babak.ashtari.com\n"
+ "babak1359.com\n"
+ "www.yahoo.com\n"
+ "babakwww.ashtari.com\n"
+ "www.tehranbazar24.com\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}