use strict;
my $str = 'https://babakashtari.combabak.com
http://babakashtari.com
https://www.babakashtari.com
babak.ashtari.com
babak1359.com
www.yahoo.com
babakwww.ashtari.com
www.tehranbazar24.com
';
my $regex = qr/^((http[s]?:\/\/|w{3}\.|http[s]?:\/\/w{3})?[a-z0-9\.]{3,}\.(com|co|net|info|tour|me|org|edu|ir))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}