const regex = /^((http[s]?:\/\/|w{3}\.|http[s]?:\/\/w{3})?[a-z0-9\.]{3,}\.(com|co|net|info|tour|me|org|edu|ir))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((http[s]?:\\\/\\\/|w{3}\\.|http[s]?:\\\/\\\/w{3})?[a-z0-9\\.]{3,}\\.(com|co|net|info|tour|me|org|edu|ir))$', 'gm')
const str = `https://babakashtari.combabak.com
http://babakashtari.com
https://www.babakashtari.com
babak.ashtari.com
babak1359.com
www.yahoo.com
babakwww.ashtari.com
www.tehranbazar24.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}