import re
regex = re.compile(r"^((http[s]?:\/\/|w{3}\.|http[s]?:\/\/w{3})?[a-z0-9\.]{3,}\.(com|co|net|info|tour|me|org|edu|ir))$", flags=re.MULTILINE)
test_str = ("https://babakashtari.combabak.com \n"
" http://babakashtari.com\n"
"https://www.babakashtari.com\n"
"babak.ashtari.com\n"
"babak1359.com\n"
"www.yahoo.com\n"
"babakwww.ashtari.com\n"
"www.tehranbazar24.com\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")