re = /^((http[s]?:\/\/|w{3}\.|http[s]?:\/\/w{3})?[a-z0-9\.]{3,}\.(com|co|net|info|tour|me|org|edu|ir))$/m
str = 'https://babakashtari.combabak.com
http://babakashtari.com
https://www.babakashtari.com
babak.ashtari.com
babak1359.com
www.yahoo.com
babakwww.ashtari.com
www.tehranbazar24.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end