using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((http[s]?:\/\/|w{3}\.|http[s]?:\/\/w{3})?[a-z0-9\.]{3,}\.(com|co|net|info|tour|me|org|edu|ir))$";
string input = @"https://babakashtari.combabak.com
http://babakashtari.com
https://www.babakashtari.com
babak.ashtari.com
babak1359.com
www.yahoo.com
babakwww.ashtari.com
www.tehranbazar24.com
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}