using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*\/)([01])(\w{32})[\/](.*)$";
string input = @"/wp-json/fy/e2/03f076b7094cd0c85c0bead50eb232c0c/settings";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}