const regex = /(.*\/)([01])(\w{32})[\/](.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*\\\/)([01])(\\w{32})[\\\/](.*)$', 'gm')
const str = `/wp-json/fy/e2/03f076b7094cd0c85c0bead50eb232c0c/settings`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}