package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*\/)([01])(\w{32})[\/](.*)$`)
var str = `/wp-json/fy/e2/03f076b7094cd0c85c0bead50eb232c0c/settings`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}