$re = '/(.*\/)([01])(\w{32})[\/](.*)$/m';
$str = '/wp-json/fy/e2/03f076b7094cd0c85c0bead50eb232c0c/settings';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);