import re
regex = re.compile(r"(.*\/)([01])(\w{32})[\/](.*)$", flags=re.MULTILINE)
test_str = "/wp-json/fy/e2/03f076b7094cd0c85c0bead50eb232c0c/settings"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")