#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\D"
Local $sString = "ID" & @CRLF & _
"Step 1" & @CRLF & _
"Step 2" & @CRLF & _
"Step 4B" & @CRLF & _
"Step 5" & @CRLF & _
"Step 6" & @CRLF & _
"Config 1" & @CRLF & _
"Config 2" & @CRLF & _
"Config 3" & @CRLF & _
"Config 4" & @CRLF & _
"Config 5" & @CRLF & _
"Config 6" & @CRLF & _
"Config 7" & @CRLF & _
"Config 8" & @CRLF & _
"Config 9" & @CRLF & _
"Config 10" & @CRLF & _
"Step 3(Option11)" & @CRLF & _
"Step 5(Option11)" & @CRLF & _
"Step 3(Option12)" & @CRLF & _
"Step 5(Option12)" & @CRLF & _
"Step 4A" & @CRLF & _
"Config 6(Option11)" & @CRLF & _
"Config 6(Option12)" & @CRLF & _
"Config 6(Option13)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")