// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\D").unwrap();
let string = "ID
Step 1
Step 2
Step 4B
Step 5
Step 6
Config 1
Config 2
Config 3
Config 4
Config 5
Config 6
Config 7
Config 8
Config 9
Config 10
Step 3(Option11)
Step 5(Option11)
Step 3(Option12)
Step 5(Option12)
Step 4A
Config 6(Option11)
Config 6(Option12)
Config 6(Option13)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}