using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\D";
string input = @"ID
Step 1
Step 2
Step 4B
Step 5
Step 6
Config 1
Config 2
Config 3
Config 4
Config 5
Config 6
Config 7
Config 8
Config 9
Config 10
Step 3(Option11)
Step 5(Option11)
Step 3(Option12)
Step 5(Option12)
Step 4A
Config 6(Option11)
Config 6(Option12)
Config 6(Option13)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}