# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\D"
test_str = ("ID\n"
"Step 1\n"
"Step 2\n"
"Step 4B\n"
"Step 5\n"
"Step 6\n"
"Config 1\n"
"Config 2\n"
"Config 3\n"
"Config 4\n"
"Config 5\n"
"Config 6\n"
"Config 7\n"
"Config 8\n"
"Config 9\n"
"Config 10\n"
"Step 3(Option11)\n"
"Step 5(Option11)\n"
"Step 3(Option12)\n"
"Step 5(Option12)\n"
"Step 4A\n"
"Config 6(Option11)\n"
"Config 6(Option12)\n"
"Config 6(Option13)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.