package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\D`)
var str = `ID
Step 1
Step 2
Step 4B
Step 5
Step 6
Config 1
Config 2
Config 3
Config 4
Config 5
Config 6
Config 7
Config 8
Config 9
Config 10
Step 3(Option11)
Step 5(Option11)
Step 3(Option12)
Step 5(Option12)
Step 4A
Config 6(Option11)
Config 6(Option12)
Config 6(Option13)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}