const regex = new RegExp('\\D', 'mg')
const str = `ID
Step 1
Step 2
Step 4B
Step 5
Step 6
Config 1
Config 2
Config 3
Config 4
Config 5
Config 6
Config 7
Config 8
Config 9
Config 10
Step 3(Option11)
Step 5(Option11)
Step 3(Option12)
Step 5(Option12)
Step 4A
Config 6(Option11)
Config 6(Option12)
Config 6(Option13)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}