import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\D";
final String string = "ID\n"
+ "Step 1\n"
+ "Step 2\n"
+ "Step 4B\n"
+ "Step 5\n"
+ "Step 6\n"
+ "Config 1\n"
+ "Config 2\n"
+ "Config 3\n"
+ "Config 4\n"
+ "Config 5\n"
+ "Config 6\n"
+ "Config 7\n"
+ "Config 8\n"
+ "Config 9\n"
+ "Config 10\n"
+ "Step 3(Option11)\n"
+ "Step 5(Option11)\n"
+ "Step 3(Option12)\n"
+ "Step 5(Option12)\n"
+ "Step 4A\n"
+ "Config 6(Option11)\n"
+ "Config 6(Option12)\n"
+ "Config 6(Option13)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}