#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<tag1[^>]*>(.*?)<\/tag1>"
Local $sString = "<tag>" & @CRLF & _
" <tag1 class=1>data1</tag1>" & @CRLF & _
" <tag2 class=2>data2</tag2>" & @CRLF & _
" <tag1 class=3>data3</tag1>" & @CRLF & _
"</tag>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")