re = /<tag1[^>]*>(.*?)<\/tag1>/
str = '<tag>
<tag1 class=1>data1</tag1>
<tag2 class=2>data2</tag2>
<tag1 class=3>data3</tag1>
</tag>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end