// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<tag1[^>]*>(.*?)<\/tag1>").unwrap();
let string = "<tag>
<tag1 class=1>data1</tag1>
<tag2 class=2>data2</tag2>
<tag1 class=3>data3</tag1>
</tag>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}