const regex = /<tag1[^>]*>(.*?)<\/tag1>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<tag1[^>]*>(.*?)<\\\/tag1>', '')
const str = `<tag>
<tag1 class=1>data1</tag1>
<tag2 class=2>data2</tag2>
<tag1 class=3>data3</tag1>
</tag>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}