import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<tag1[^>]*>(.*?)<\\/tag1>";
final String string = "<tag>\n"
+ " <tag1 class=1>data1</tag1>\n"
+ " <tag2 class=2>data2</tag2>\n"
+ " <tag1 class=3>data3</tag1>\n"
+ "</tag>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}