package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(?|<h3>(.+?)</h3>|<h4>(.+?)</h4>)`)
var str = `<h3>foo</h3>
<h4>bar</h4>
<h3>title</h4>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}