$re = '~(?|<h3>(.+?)</h3>|<h4>(.+?)</h4>)~s';
$str = '<h3>foo</h3>
<h4>bar</h4>
<h3>title</h4>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);