import re
regex = re.compile(r"(?|<h3>(.+?)</h3>|<h4>(.+?)</h4>)", flags=re.DOTALL)
test_str = ("<h3>foo</h3>\n"
"<h4>bar</h4>\n"
"<h3>title</h4>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")