re = /(?|<h3>(.+?)<\/h3>|<h4>(.+?)<\/h4>)/
str = '<h3>foo</h3>
<h4>bar</h4>
<h3>title</h4>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end