#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\b)(\d{5})(\b)"
Local $sString = ">123<" & @CRLF & _
" 123-" & @CRLF & _
"123" & @CRLF & _
"abc123def" & @CRLF & _
"abc1234def" & @CRLF & _
"12345" & @CRLF & _
"jkfjg2342395" & @CRLF & _
"kdjfd 23423 " & @CRLF & _
"ที่ 20025-28" & @CRLF & _
"ที่ 2002528 " & @CRLF & _
"ที่a20025a28" & @CRLF & _
"" & @CRLF & _
"ที่ 20025-28"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")