re = /(\b)(\d{5})(\b)/m
str = '>123<
123-
123
abc123def
abc1234def
12345
jkfjg2342395
kdjfd 23423
ที่ 20025-28
ที่ 2002528
ที่a20025a28
ที่ 20025-28'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end