const regex = /(\b)(\d{5})(\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b)(\\d{5})(\\b)', 'gm')
const str = `>123<
123-
123
abc123def
abc1234def
12345
jkfjg2342395
kdjfd 23423
ที่ 20025-28
ที่ 2002528
ที่a20025a28
ที่ 20025-28`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}