import re
regex = re.compile(r"(\b)(\d{5})(\b)", flags=re.MULTILINE)
test_str = (">123<\n"
" 123-\n"
"123\n"
"abc123def\n"
"abc1234def\n"
"12345\n"
"jkfjg2342395\n"
"kdjfd 23423 \n"
"ที่ 20025-28\n"
"ที่ 2002528 \n"
"ที่a20025a28\n\n"
"ที่ 20025-28")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")