import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b)(\\d{5})(\\b)";
final String string = ">123<\n"
+ " 123-\n"
+ "123\n"
+ "abc123def\n"
+ "abc1234def\n"
+ "12345\n"
+ "jkfjg2342395\n"
+ "kdjfd 23423 \n"
+ "ที่ 20025-28\n"
+ "ที่ 2002528 \n"
+ "ที่a20025a28\n\n"
+ "ที่ 20025-28";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}