// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\b)(\d{5})(\b)").unwrap();
let string = ">123<
123-
123
abc123def
abc1234def
12345
jkfjg2342395
kdjfd 23423
ที่ 20025-28
ที่ 2002528
ที่a20025a28
ที่ 20025-28";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}