#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^((https?)\:\/\/)(([a-z0-9])+\.)*(google\.com)"
Local $sString = "https://www.adwords.google.com" & @CRLF & _
"https://www.google.com/grants" & @CRLF & _
"https://tracKing3.google.com/redirect?url=https%3A%2F%2Fwww.google.com%2Fgrants" & @CRLF & _
"http://google.com" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http://google.com/" & @CRLF & _
"http://...asd..a.google.com" & @CRLF & _
"http://####.google.com" & @CRLF & _
"" & @CRLF & _
"https://www.dasistkeingoogle.com" & @CRLF & _
"https://www.adwords.fr" & @CRLF & _
"https://www.adwords.com" & @CRLF & _
"https://thirdpartytracking.com" & @CRLF & _
"https://thirdpartytracking.com/?url=https%3A%2F%2Fwww.google.com%2Fgrants"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")