# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((https?)\:\/\/)(([a-z0-9])+\.)*(google\.com)"
test_str = ("https://www.adwords.google.com\n"
"https://www.google.com/grants\n"
"https://tracKing3.google.com/redirect?url=https%3A%2F%2Fwww.google.com%2Fgrants\n"
"http://google.com\n\n\n"
"http://google.com/\n"
"http://...asd..a.google.com\n"
"http://####.google.com\n\n"
"https://www.dasistkeingoogle.com\n"
"https://www.adwords.fr\n"
"https://www.adwords.com\n"
"https://thirdpartytracking.com\n"
"https://thirdpartytracking.com/?url=https%3A%2F%2Fwww.google.com%2Fgrants")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.