import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((https?)\\:\\/\\/)(([a-z0-9])+\\.)*(google\\.com)";
final String string = "https://www.adwords.google.com\n"
+ "https://www.google.com/grants\n"
+ "https://tracKing3.google.com/redirect?url=https%3A%2F%2Fwww.google.com%2Fgrants\n"
+ "http://google.com\n\n\n"
+ "http://google.com/\n"
+ "http://...asd..a.google.com\n"
+ "http://####.google.com\n\n"
+ "https://www.dasistkeingoogle.com\n"
+ "https://www.adwords.fr\n"
+ "https://www.adwords.com\n"
+ "https://thirdpartytracking.com\n"
+ "https://thirdpartytracking.com/?url=https%3A%2F%2Fwww.google.com%2Fgrants";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}