use strict;
my $str = 'https://www.adwords.google.com
https://www.google.com/grants
https://tracKing3.google.com/redirect?url=https%3A%2F%2Fwww.google.com%2Fgrants
http://google.com
http://google.com/
http://...asd..a.google.com
http://####.google.com
https://www.dasistkeingoogle.com
https://www.adwords.fr
https://www.adwords.com
https://thirdpartytracking.com
https://thirdpartytracking.com/?url=https%3A%2F%2Fwww.google.com%2Fgrants';
my $regex = qr/^((https?)\:\/\/)(([a-z0-9])+\.)*(google\.com)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}