const regex = /^((https?)\:\/\/)(([a-z0-9])+\.)*(google\.com)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((https?)\\:\\\/\\\/)(([a-z0-9])+\\.)*(google\\.com)', 'gmi')
const str = `https://www.adwords.google.com
https://www.google.com/grants
https://tracKing3.google.com/redirect?url=https%3A%2F%2Fwww.google.com%2Fgrants
http://google.com
http://google.com/
http://...asd..a.google.com
http://####.google.com
https://www.dasistkeingoogle.com
https://www.adwords.fr
https://www.adwords.com
https://thirdpartytracking.com
https://thirdpartytracking.com/?url=https%3A%2F%2Fwww.google.com%2Fgrants`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}