re = /^((https?)\:\/\/)(([a-z0-9])+\.)*(google\.com)/mi
str = 'https://www.adwords.google.com
https://www.google.com/grants
https://tracKing3.google.com/redirect?url=https%3A%2F%2Fwww.google.com%2Fgrants
http://google.com
http://google.com/
http://...asd..a.google.com
http://####.google.com
https://www.dasistkeingoogle.com
https://www.adwords.fr
https://www.adwords.com
https://thirdpartytracking.com
https://thirdpartytracking.com/?url=https%3A%2F%2Fwww.google.com%2Fgrants'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end