using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((https?)\:\/\/)(([a-z0-9])+\.)*(google\.com)";
string input = @"https://www.adwords.google.com
https://www.google.com/grants
https://tracKing3.google.com/redirect?url=https%3A%2F%2Fwww.google.com%2Fgrants
http://google.com
http://google.com/
http://...asd..a.google.com
http://####.google.com
https://www.dasistkeingoogle.com
https://www.adwords.fr
https://www.adwords.com
https://thirdpartytracking.com
https://thirdpartytracking.com/?url=https%3A%2F%2Fwww.google.com%2Fgrants";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}