using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.*href\s{0,}=\s{0,}"".*_.*"".*>(.*)<\/a>";
string input = @"deepak<a href=""cc"">deepak</a>sharma<a href=""http://deepak.sharma-sharma.com"">deepak</a> sharm <a href=""http://deepak.sharma_sharma.com"">deepak</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}