// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<a.*href\s{0,}=\s{0,}".*_.*".*>(.*)<\/a>"#).unwrap();
let string = "deepak<a href=\"cc\">deepak</a>sharma<a href=\"http://deepak.sharma-sharma.com\">deepak</a> sharm <a href=\"http://deepak.sharma_sharma.com\">deepak</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}