package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a.*href\s{0,}=\s{0,}".*_.*".*>(.*)<\/a>`)
var str = `deepak<a href="cc">deepak</a>sharma<a href="http://deepak.sharma-sharma.com">deepak</a> sharm <a href="http://deepak.sharma_sharma.com">deepak</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}