const regex = /<a.*href\s{0,}=\s{0,}".*_.*".*>(.*)<\/a>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a.*href\\s{0,}=\\s{0,}".*_.*".*>(.*)<\\\/a>', 'g')
const str = `deepak<a href="cc">deepak</a>sharma<a href="http://deepak.sharma-sharma.com">deepak</a> sharm <a href="http://deepak.sharma_sharma.com">deepak</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}