use strict;
my $str = 'deepak<a href="cc">deepak</a>sharma<a href="http://deepak.sharma-sharma.com">deepak</a> sharm <a href="http://deepak.sharma_sharma.com">deepak</a>';
my $regex = qr/<a.*href\s{0,}=\s{0,}".*_.*".*>(.*)<\/a>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}